Author Topic: Mailsmith is the email client you love and trust for Mac OS X 10.4 or later  (Read 1641 times)

0 Members and 1 Guest are viewing this topic.

Software Santa

  • Administrator
  • *****
  • Posts: 4281
Mailsmith is the email client you love and trust for Mac OS X 10.4 or later

Quote

Welcome to mailsmith.org, the home of Mailsmith. Here you will find the latest available software and links to companion products and additions, support resources, and other information to help you make the most of this standards-based desktop email client for Mac OS X.

If you’re an existing Mailsmith customer: be happy! The email client you love and trust is here.

If you’re just hearing about Mailsmith for the first time: welcome! We’re a little thin on product details at the moment, but feel free to download and try it out…


Universal binary: This version of Mailsmith runs natively on Intel Macs.

System Requirements: Mailsmith 2.2 requires Mac OS X 10.4 or later. 10.5.8 or later is recommended: Mailsmith will run on 10.4 and is "officially" supported, but we really do recommend that you use at least a 10.5.x version of the OS if at all possible.

Mailsmith is compatible and supported on Mac OS X 10.5.8 and later (including 10.6).

You will not be able to run Mailsmith 2.2 on any version of the OS older than 10.4.

http://www.mailsmith.org/download/

 

email